summaryrefslogtreecommitdiffstats
path: root/third_party/aom/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/aom/CMakeLists.txt')
-rw-r--r--third_party/aom/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/third_party/aom/CMakeLists.txt b/third_party/aom/CMakeLists.txt
index 0b445722d..0f6a37ffb 100644
--- a/third_party/aom/CMakeLists.txt
+++ b/third_party/aom/CMakeLists.txt
@@ -186,9 +186,11 @@ list(APPEND AOM_ENCODER_APP_UTIL_SOURCES
"${AOM_ROOT}/examples/encoder_util.h"
"${AOM_ROOT}/examples/encoder_util.c")
-list(APPEND AOM_ENCODER_STATS_SOURCES "${AOM_ROOT}/stats/aomstats.c"
- "${AOM_ROOT}/stats/aomstats.h" "${AOM_ROOT}/stats/rate_hist.c"
- "${AOM_ROOT}/stats/rate_hist.h")
+if (ENABLE_EXAMPLES)
+ list(APPEND AOM_ENCODER_STATS_SOURCES "${AOM_ROOT}/stats/aomstats.c"
+ "${AOM_ROOT}/stats/aomstats.h" "${AOM_ROOT}/stats/rate_hist.c"
+ "${AOM_ROOT}/stats/rate_hist.h")
+endif ()
list(APPEND AOM_PKG_CONFIG_SOURCES "${AOM_CONFIG_DIR}/aom.pc")