summaryrefslogtreecommitdiffstats
path: root/third_party/aom/CMakeLists.txt
diff options
context:
space:
mode:
authortrav90 <travawine@palemoon.org>2018-10-19 21:55:15 -0500
committertrav90 <travawine@palemoon.org>2018-10-19 21:55:15 -0500
commitab5b4462a2c677ba18275c2146d7de4d296bc8e9 (patch)
tree4e1976f614f1d945dc63b79f2a9c06553c51ec4e /third_party/aom/CMakeLists.txt
parentbbcc64772580c8a979288791afa02d30bc476d2e (diff)
downloadUXP-ab5b4462a2c677ba18275c2146d7de4d296bc8e9.tar
UXP-ab5b4462a2c677ba18275c2146d7de4d296bc8e9.tar.gz
UXP-ab5b4462a2c677ba18275c2146d7de4d296bc8e9.tar.lz
UXP-ab5b4462a2c677ba18275c2146d7de4d296bc8e9.tar.xz
UXP-ab5b4462a2c677ba18275c2146d7de4d296bc8e9.zip
Do not build aomstats unless examples are enabled
The aomstats library is only used in the code examples, but we assume that all libraries should be linked into libxul, which leads to an unresolved external dependency on fatal at link time. This adds a guard to only build aomstats if we are building the examples.
Diffstat (limited to 'third_party/aom/CMakeLists.txt')
-rw-r--r--third_party/aom/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/third_party/aom/CMakeLists.txt b/third_party/aom/CMakeLists.txt
index 0b445722d..0f6a37ffb 100644
--- a/third_party/aom/CMakeLists.txt
+++ b/third_party/aom/CMakeLists.txt
@@ -186,9 +186,11 @@ list(APPEND AOM_ENCODER_APP_UTIL_SOURCES
"${AOM_ROOT}/examples/encoder_util.h"
"${AOM_ROOT}/examples/encoder_util.c")
-list(APPEND AOM_ENCODER_STATS_SOURCES "${AOM_ROOT}/stats/aomstats.c"
- "${AOM_ROOT}/stats/aomstats.h" "${AOM_ROOT}/stats/rate_hist.c"
- "${AOM_ROOT}/stats/rate_hist.h")
+if (ENABLE_EXAMPLES)
+ list(APPEND AOM_ENCODER_STATS_SOURCES "${AOM_ROOT}/stats/aomstats.c"
+ "${AOM_ROOT}/stats/aomstats.h" "${AOM_ROOT}/stats/rate_hist.c"
+ "${AOM_ROOT}/stats/rate_hist.h")
+endif ()
list(APPEND AOM_PKG_CONFIG_SOURCES "${AOM_CONFIG_DIR}/aom.pc")