summaryrefslogtreecommitdiffstats
path: root/testing/mozbase/mozprofile/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mozbase/mozprofile/setup.py')
-rw-r--r--testing/mozbase/mozprofile/setup.py45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/mozbase/mozprofile/setup.py b/testing/mozbase/mozprofile/setup.py
new file mode 100644
index 000000000..a88fe7053
--- /dev/null
+++ b/testing/mozbase/mozprofile/setup.py
@@ -0,0 +1,45 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+
+import sys
+from setuptools import setup
+
+PACKAGE_NAME = 'mozprofile'
+PACKAGE_VERSION = '0.28'
+
+# we only support python 2 right now
+assert sys.version_info[0] == 2
+
+deps = ['mozfile >= 1.0', 'mozlog >= 3.0']
+
+setup(name=PACKAGE_NAME,
+ version=PACKAGE_VERSION,
+ description="Library to create and modify Mozilla application profiles",
+ long_description="see http://mozbase.readthedocs.org/",
+ classifiers=['Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ],
+ keywords='mozilla',
+ author='Mozilla Automation and Tools team',
+ author_email='tools@lists.mozilla.org',
+ url='https://wiki.mozilla.org/Auto-tools/Projects/Mozbase',
+ license='MPL 2.0',
+ packages=['mozprofile'],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=deps,
+ extras_require={'manifest': ['manifestparser >= 0.6']},
+ tests_require=['mozhttpd'],
+ entry_points="""
+ # -*- Entry points: -*-
+ [console_scripts]
+ mozprofile = mozprofile:cli
+ view-profile = mozprofile:view_profile
+ diff-profiles = mozprofile:diff_profiles
+ """, )