summaryrefslogtreecommitdiffstats
path: root/testing/mozbase/manifestparser/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mozbase/manifestparser/setup.py')
-rw-r--r--testing/mozbase/manifestparser/setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/mozbase/manifestparser/setup.py b/testing/mozbase/manifestparser/setup.py
new file mode 100644
index 000000000..b34f9cea7
--- /dev/null
+++ b/testing/mozbase/manifestparser/setup.py
@@ -0,0 +1,27 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import setup
+
+PACKAGE_NAME = "manifestparser"
+PACKAGE_VERSION = '1.1'
+
+setup(name=PACKAGE_NAME,
+ version=PACKAGE_VERSION,
+ description="Library to create and manage test manifests",
+ long_description="see http://mozbase.readthedocs.org/",
+ classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ keywords='mozilla manifests',
+ author='Mozilla Automation and Testing Team',
+ author_email='tools@lists.mozilla.org',
+ url='https://wiki.mozilla.org/Auto-tools/Projects/Mozbase',
+ license='MPL',
+ zip_safe=False,
+ packages=['manifestparser'],
+ install_requires=[],
+ entry_points="""
+ [console_scripts]
+ manifestparser = manifestparser.cli:main
+ """,
+ )