summaryrefslogtreecommitdiffstats
path: root/api/logic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'api/logic/CMakeLists.txt')
-rw-r--r--api/logic/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/api/logic/CMakeLists.txt b/api/logic/CMakeLists.txt
index 3d5687b0..404044d8 100644
--- a/api/logic/CMakeLists.txt
+++ b/api/logic/CMakeLists.txt
@@ -418,6 +418,20 @@ set(META_SOURCES
meta/Index.h
)
+set(MODPLATFORM_SOURCES
+ # Modplatform sources
+ modplatform/FtbPackDownloader.h
+ modplatform/FtbPackDownloader.cpp
+
+ modplatform/FtbPackFetchTask.h
+ modplatform/FtbPackFetchTask.cpp
+ modplatform/FtbPackInstallTask.h
+ modplatform/FtbPackInstallTask.cpp
+
+ modplatform/PackHelpers.h
+
+)
+
add_unit_test(Index
SOURCES meta/Index_test.cpp
LIBS MultiMC_logic
@@ -446,6 +460,7 @@ set(LOGIC_SOURCES
${TOOLS_SOURCES}
${META_SOURCES}
${ICONS_SOURCES}
+ ${MODPLATFORM_SOURCES}
)
add_library(MultiMC_logic SHARED ${LOGIC_SOURCES})