summaryrefslogtreecommitdiffstats
path: root/quazip/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2013-01-11 02:25:40 +0100
committerPetr Mrázek <peterix@gmail.com>2013-01-11 02:25:40 +0100
commitb1d00fce8da901b31fa52ea59b4bc3c8edb9d9cc (patch)
treef7c909b4080e6d1868e601609741450330dc9a1e /quazip/CMakeLists.txt
parentd6d5c86a736537828a59ddc6389d5d0490942f8c (diff)
downloadMultiMC-b1d00fce8da901b31fa52ea59b4bc3c8edb9d9cc.tar
MultiMC-b1d00fce8da901b31fa52ea59b4bc3c8edb9d9cc.tar.gz
MultiMC-b1d00fce8da901b31fa52ea59b4bc3c8edb9d9cc.tar.lz
MultiMC-b1d00fce8da901b31fa52ea59b4bc3c8edb9d9cc.tar.xz
MultiMC-b1d00fce8da901b31fa52ea59b4bc3c8edb9d9cc.zip
CMake build system, big pile of libs: bspatch, quazip, java, the launcher
Diffstat (limited to 'quazip/CMakeLists.txt')
-rw-r--r--quazip/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/quazip/CMakeLists.txt b/quazip/CMakeLists.txt
new file mode 100644
index 00000000..b245653f
--- /dev/null
+++ b/quazip/CMakeLists.txt
@@ -0,0 +1,26 @@
+# set all include directories for in and out of source builds
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${ZLIB_INCLUDE_DIRS}
+)
+
+# include with QT_USE selected library parts
+# INCLUDE(${QT_USE_FILE})
+
+file(GLOB SRCS "*.c" "*.cpp")
+file(GLOB PUBLIC_HEADERS "*.h")
+
+# Must be added to enable export macro
+ADD_DEFINITIONS(-DQUAZIP_BUILD)
+
+#qt5_wrap_cpp(MOC_SRCS ${PUBLIC_HEADERS})
+#set(SRCS ${SRCS} ${MOC_SRCS})
+
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+
+add_library(quazip STATIC ${SRCS})
+target_link_libraries(quazip ${ZLIB_LIBRARIES})
+
+#install(FILES ${PUBLIC_HEADERS} DESTINATION include/quazip)
+#install(TARGETS quazip LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})