summaryrefslogtreecommitdiffstats
path: root/application/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2017-01-05 04:05:08 +0100
committerPetr Mrázek <peterix@gmail.com>2017-01-05 04:05:08 +0100
commite1bd1c614519974d7bfc0efc8dcbfafa9418e2fa (patch)
tree2592a85455ff45925eaa19e8023061a5089be89a /application/CMakeLists.txt
parent4c0db2b99decf407b1f5cf0afc6f29db87ac03ca (diff)
downloadMultiMC-e1bd1c614519974d7bfc0efc8dcbfafa9418e2fa.tar
MultiMC-e1bd1c614519974d7bfc0efc8dcbfafa9418e2fa.tar.gz
MultiMC-e1bd1c614519974d7bfc0efc8dcbfafa9418e2fa.tar.lz
MultiMC-e1bd1c614519974d7bfc0efc8dcbfafa9418e2fa.tar.xz
MultiMC-e1bd1c614519974d7bfc0efc8dcbfafa9418e2fa.zip
NOISSUE feature complete setup wizard
Diffstat (limited to 'application/CMakeLists.txt')
-rw-r--r--application/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/application/CMakeLists.txt b/application/CMakeLists.txt
index e51e6eb1..2814d6be 100644
--- a/application/CMakeLists.txt
+++ b/application/CMakeLists.txt
@@ -114,6 +114,13 @@ SET(MULTIMC_SOURCES
# GUI - setup wizard
setupwizard/SetupWizard.h
setupwizard/SetupWizard.cpp
+ setupwizard/AnalyticsWizardPage.cpp
+ setupwizard/AnalyticsWizardPage.h
+ setupwizard/BaseWizardPage.h
+ setupwizard/JavaWizardPage.cpp
+ setupwizard/JavaWizardPage.h
+ setupwizard/LanguageWizardPage.cpp
+ setupwizard/LanguageWizardPage.h
# GUI - themes
themes/FusionTheme.cpp
@@ -246,6 +253,8 @@ SET(MULTIMC_SOURCES
widgets/ServerStatus.h
widgets/VersionListView.cpp
widgets/VersionListView.h
+ widgets/VersionSelectWidget.cpp
+ widgets/VersionSelectWidget.h
widgets/ProgressWidget.h
widgets/ProgressWidget.cpp
@@ -289,7 +298,6 @@ SET(MULTIMC_UIS
dialogs/CopyInstanceDialog.ui
dialogs/NewInstanceDialog.ui
dialogs/AboutDialog.ui
- dialogs/VersionSelectDialog.ui
dialogs/ProgressDialog.ui
dialogs/IconPickerDialog.ui
dialogs/ProfileSelectDialog.ui