summaryrefslogtreecommitdiffstats
path: root/application/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2016-01-04 01:37:46 +0100
committerPetr Mrázek <peterix@gmail.com>2016-01-04 01:37:46 +0100
commit6f92ca843e6d1c4f8ef2be5ceba361cd74b79250 (patch)
tree97a6b948906ef667712eb78a2a5a413b79788a32 /application/CMakeLists.txt
parent8cf23bd5aa0295c8582c74617086c233cb9552a6 (diff)
downloadMultiMC-6f92ca843e6d1c4f8ef2be5ceba361cd74b79250.tar
MultiMC-6f92ca843e6d1c4f8ef2be5ceba361cd74b79250.tar.gz
MultiMC-6f92ca843e6d1c4f8ef2be5ceba361cd74b79250.tar.lz
MultiMC-6f92ca843e6d1c4f8ef2be5ceba361cd74b79250.tar.xz
MultiMC-6f92ca843e6d1c4f8ef2be5ceba361cd74b79250.zip
GH-1389 remove use of LD_LIBRARY_PATH for mmc libs
Diffstat (limited to 'application/CMakeLists.txt')
-rw-r--r--application/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/application/CMakeLists.txt b/application/CMakeLists.txt
index 65bee8c9..75f7d78e 100644
--- a/application/CMakeLists.txt
+++ b/application/CMakeLists.txt
@@ -71,6 +71,11 @@ endif()
# directories to look for dependencies
set(DIRS ${QT_LIBS_DIR} ${QT_LIBEXECS_DIR} ${CMAKE_LIBRARY_OUTPUT_DIRECTORY} ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
+# Install RPATH - let's not use LD_LIBRARY_PATH
+if(UNIX AND NOT APPLE)
+ set(CMAKE_INSTALL_RPATH "\\\$ORIGIN")
+endif()
+
################################ FILES ################################
######## Sources and headers ########