summaryrefslogtreecommitdiffstats
path: root/application/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2017-05-06 03:39:54 +0200
committerPetr Mrázek <peterix@gmail.com>2017-05-06 03:41:11 +0200
commit4183cc203fa090d9a11429938d61cc1418a9433b (patch)
tree09c2e2c64bf804c84548e44425d64eb0238526ba /application/CMakeLists.txt
parent2b3e87b7d10eb0db4dd21f25cf11312762b7032f (diff)
downloadMultiMC-4183cc203fa090d9a11429938d61cc1418a9433b.tar
MultiMC-4183cc203fa090d9a11429938d61cc1418a9433b.tar.gz
MultiMC-4183cc203fa090d9a11429938d61cc1418a9433b.tar.lz
MultiMC-4183cc203fa090d9a11429938d61cc1418a9433b.tar.xz
MultiMC-4183cc203fa090d9a11429938d61cc1418a9433b.zip
NOISSUE add back qt.conf on macOS
Looks like it doesn't start without this magical empty file. Who would have guessed? Not me.
Diffstat (limited to 'application/CMakeLists.txt')
-rw-r--r--application/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/application/CMakeLists.txt b/application/CMakeLists.txt
index 0821aa6c..1d2880d6 100644
--- a/application/CMakeLists.txt
+++ b/application/CMakeLists.txt
@@ -348,6 +348,12 @@ if(MultiMC_LAYOUT_REAL STREQUAL "mac-bundle")
# Add the icon
install(FILES resources/MultiMC.icns DESTINATION ${RESOURCES_DEST_DIR})
+
+ # Add qt.conf - because for some reason, an empty file is needed to make things work on macOS
+ install(
+ CODE "file(WRITE \"\${CMAKE_INSTALL_PREFIX}/${RESOURCES_DEST_DIR}/qt.conf\" \"\")"
+ COMPONENT Runtime
+ )
elseif(MultiMC_LAYOUT_REAL STREQUAL "lin-bundle")
set(BINARY_DEST_DIR "bin")
set(LIBRARY_DEST_DIR "bin")