summaryrefslogtreecommitdiffstats
path: root/application/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2017-05-06 17:22:14 +0200
committerPetr Mrázek <peterix@gmail.com>2017-05-06 17:36:57 +0200
commit15c829fd3ce0de04db938566a56e66531c320580 (patch)
tree629ca7ea6d2433a1c6dafdf0c4268ef21f30e7f8 /application/CMakeLists.txt
parent349381cb2b930263dda875945b912b74656fd847 (diff)
downloadMultiMC-15c829fd3ce0de04db938566a56e66531c320580.tar
MultiMC-15c829fd3ce0de04db938566a56e66531c320580.tar.gz
MultiMC-15c829fd3ce0de04db938566a56e66531c320580.tar.lz
MultiMC-15c829fd3ce0de04db938566a56e66531c320580.tar.xz
MultiMC-15c829fd3ce0de04db938566a56e66531c320580.zip
GH-1876 Fork and update quazip
* It is added as a new submodule: https://github.com/MultiMC/quazip/tree/multimc-1 * Its build system has been entirely replaced to remove the existing issues with it * It now has working unit tests * No more patches needed * It has a static linking exception in its license now, but we use it shared anyway
Diffstat (limited to 'application/CMakeLists.txt')
-rw-r--r--application/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/application/CMakeLists.txt b/application/CMakeLists.txt
index 1ce9e6cd..146ee38f 100644
--- a/application/CMakeLists.txt
+++ b/application/CMakeLists.txt
@@ -411,7 +411,7 @@ else()
message(FATAL_ERROR "No sensible install layout set.")
endif()
-######## Install base files ########
+######## Install files ########
#### Executable ####
install(TARGETS MultiMC
@@ -427,12 +427,13 @@ install_jar(NewLaunch "${BINARY_DEST_DIR}/jars")
#### Shared libraries and dependencies ####
if(NOT INSTALL_BUNDLE)
# Just our own stuff
- # FIXME: this does not fix RPATH.
+ # FIXME: this does not remove RPATH.
install(
FILES
$<TARGET_FILE:MultiMC_gui>
$<TARGET_FILE:MultiMC_logic>
$<TARGET_FILE:MultiMC_rainbow>
+ $<TARGET_FILE:MultiMC_quazip>
$<TARGET_FILE:MultiMC_iconfix>
$<TARGET_FILE:MultiMC_unpack200>
$<TARGET_FILE:MultiMC_nbt++>