summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew <forkk@forkk.net>2013-12-10 13:37:15 -0600
committerAndrew <forkk@forkk.net>2013-12-10 13:37:15 -0600
commitf0104edc3daded9aa09e5a1b6dbfe2cc39d495dd (patch)
tree2090aa1c0fc49904d3cf32edd1f0b73d8a952f20 /CMakeLists.txt
parentaa61bbe9e414648399aff2802df5b587dee1a084 (diff)
downloadMultiMC-f0104edc3daded9aa09e5a1b6dbfe2cc39d495dd.tar
MultiMC-f0104edc3daded9aa09e5a1b6dbfe2cc39d495dd.tar.gz
MultiMC-f0104edc3daded9aa09e5a1b6dbfe2cc39d495dd.tar.lz
MultiMC-f0104edc3daded9aa09e5a1b6dbfe2cc39d495dd.tar.xz
MultiMC-f0104edc3daded9aa09e5a1b6dbfe2cc39d495dd.zip
Move fixup_bundle CMake stuff into a separate file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 5 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ccf2bde3..a413c700 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -576,22 +576,11 @@ FILE(WRITE \"\${CMAKE_INSTALL_PREFIX}/${QTCONF_DEST_DIR}/qt.conf\" \"\")
COMPONENT Runtime
)
-
-INSTALL(
- CODE "
-FILE(GLOB_RECURSE QTPLUGINS \"\${CMAKE_INSTALL_PREFIX}/${PLUGIN_DEST_DIR}/*${CMAKE_SHARED_LIBRARY_SUFFIX}\")
-function(gp_resolved_file_type_override resolved_file type_var)
- if(resolved_file MATCHES \"^/usr/lib/libQt\")
- message(\"resolving \${resolved_file} as other\")
- set(\${type_var} other PARENT_SCOPE)
- endif()
-endfunction()
-
-include(BundleUtilities)
-fixup_bundle(\"${APPS}\" \"\${QTPLUGINS}\" \"${DIRS}\")
-"
- COMPONENT Runtime
-)
+CONFIGURE_FILE(
+ "${CMAKE_CURRENT_SOURCE_DIR}/install_prereqs.cmake.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/install_prereqs.cmake"
+ @ONLY)
+INSTALL(SCRIPT "${CMAKE_CURRENT_BINARY_DIR}/install_prereqs.cmake" COMPONENT Runtime)