summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2015-05-26 22:38:01 +0200
committerPetr Mrázek <peterix@gmail.com>2015-05-26 22:38:01 +0200
commit50a4a1e19ef148972eb9eb116f0fdd1b6b0bcdda (patch)
tree02e13691783cf38d9af859240e182e64c0f9bcda /CMakeLists.txt
parent2f087b55b919d1aa27c32685209886a960b0ae57 (diff)
downloadMultiMC-50a4a1e19ef148972eb9eb116f0fdd1b6b0bcdda.tar
MultiMC-50a4a1e19ef148972eb9eb116f0fdd1b6b0bcdda.tar.gz
MultiMC-50a4a1e19ef148972eb9eb116f0fdd1b6b0bcdda.tar.lz
MultiMC-50a4a1e19ef148972eb9eb116f0fdd1b6b0bcdda.tar.xz
MultiMC-50a4a1e19ef148972eb9eb116f0fdd1b6b0bcdda.zip
NOISSUE use -fPIC builds when the system Qt is derpy
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fde28a4c..342ddbe4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,6 +68,10 @@ query_qmake(QT_INSTALL_LIBEXECS QT_LIBEXECS_DIR)
query_qmake(QT_HOST_DATA QT_DATA_DIR)
set(QT_MKSPECS_DIR ${QT_DATA_DIR}/mkspecs)
+if (Qt5_POSITION_INDEPENDENT_CODE)
+ SET(CMAKE_POSITION_INDEPENDENT_CODE ON)
+endif()
+
################################ Included Libs ################################
include(ExternalProject)