summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Dalheimer <jan@dalheimer.de>2016-01-06 08:47:31 +0100
committerJan Dalheimer <jan@dalheimer.de>2016-01-06 10:33:47 +0100
commit34bf4ccdc749cdc7327bfcd450e04deaf1989b78 (patch)
tree1b19115d510163457cc7622385dfaea962bdebe6 /CMakeLists.txt
parentaa8103adf21acb2ad88044f2c2e728b2d6649f2c (diff)
downloadMultiMC-34bf4ccdc749cdc7327bfcd450e04deaf1989b78.tar
MultiMC-34bf4ccdc749cdc7327bfcd450e04deaf1989b78.tar.gz
MultiMC-34bf4ccdc749cdc7327bfcd450e04deaf1989b78.tar.lz
MultiMC-34bf4ccdc749cdc7327bfcd450e04deaf1989b78.tar.xz
MultiMC-34bf4ccdc749cdc7327bfcd450e04deaf1989b78.zip
NOISSUE Add more qt versions to travis
5.0, 5.1 and 5.2 are currently marked as "allow failure". If they can be made to pass they should be removed from this list, if not they should be removed entirely.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f432f851..73f3d1d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,7 +48,12 @@ include(Coverity)
################################ 3rd Party Libs ################################
# Find the required Qt parts
-find_package(Qt5 COMPONENTS Core Widgets Concurrent Network Test Xml)
+find_package(Qt5Core)
+find_package(Qt5Widgets)
+find_package(Qt5Concurrent)
+find_package(Qt5Network)
+find_package(Qt5Test)
+find_package(Qt5Xml)
# The Qt5 cmake files don't provide its install paths, so ask qmake.
include(QMakeQuery)