summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2015-09-28 21:20:27 +0200
committerPetr Mrázek <peterix@gmail.com>2015-09-28 21:20:27 +0200
commit260a2cea593b9f2211879a80d1d5d377592678da (patch)
treea1f8b254dc13f2fb477a92593938c676fc35ed97 /CMakeLists.txt
parent143e24fa04f0126d91b65b4035dd6ec556c79b00 (diff)
downloadMultiMC-260a2cea593b9f2211879a80d1d5d377592678da.tar
MultiMC-260a2cea593b9f2211879a80d1d5d377592678da.tar.gz
MultiMC-260a2cea593b9f2211879a80d1d5d377592678da.tar.lz
MultiMC-260a2cea593b9f2211879a80d1d5d377592678da.tar.xz
MultiMC-260a2cea593b9f2211879a80d1d5d377592678da.zip
NOISSUE more cmake tweakery
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 37e5314e..c896de08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,9 +94,9 @@ add_subdirectory(depends/xz-embedded) # xz compression
add_subdirectory(depends/pack200) # java pack200 compression
add_subdirectory(depends/rainbow) # Qt extension for colors
-set(NBT_BUILD_SHARED ON CACHE BOOL "Build NBT shared library")
-set(NBT_USE_ZLIB OFF CACHE BOOL "Build NBT library with zlib support")
-set(NBT_BUILD_TESTS OFF CACHE BOOL "Build NBT library tests") #FIXME: fix unit tests.
+option(NBT_BUILD_SHARED "Build NBT shared library" ON)
+option(NBT_USE_ZLIB "Build NBT library with zlib support" OFF)
+option(NBT_BUILD_TESTS "Build NBT library tests" OFF) #FIXME: fix unit tests.
add_subdirectory(depends/libnbtplusplus)
######## MultiMC Libs ########