summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2016-12-28 17:23:48 +0100
committerPetr Mrázek <peterix@gmail.com>2016-12-28 17:23:48 +0100
commit2344ee2dcd2c0f8755257ed092ccb652b4733330 (patch)
tree600f69e11a38ffd1114942fb291ed464b7abf19c /CMakeLists.txt
parent481ecb178c646ccb9aa7dd825e9d7e0b0883c47e (diff)
downloadMultiMC-2344ee2dcd2c0f8755257ed092ccb652b4733330.tar
MultiMC-2344ee2dcd2c0f8755257ed092ccb652b4733330.tar.gz
MultiMC-2344ee2dcd2c0f8755257ed092ccb652b4733330.tar.lz
MultiMC-2344ee2dcd2c0f8755257ed092ccb652b4733330.tar.xz
MultiMC-2344ee2dcd2c0f8755257ed092ccb652b4733330.zip
GH-1379 rename shared libraries to avoid collisions with system libraries
It was unlikely, now it's impossible.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52268530..69827ee1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -89,6 +89,7 @@ endif()
option(NBT_BUILD_SHARED "Build NBT shared library" ON)
option(NBT_USE_ZLIB "Build NBT library with zlib support" OFF)
option(NBT_BUILD_TESTS "Build NBT library tests" OFF) #FIXME: fix unit tests.
+set(NBT_NAME MultiMC_nbt++)
add_subdirectory(libraries/libnbtplusplus)
add_subdirectory(libraries/ganalytics) # google analytics library