summaryrefslogtreecommitdiffstats
path: root/api/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'api/gui/CMakeLists.txt')
-rw-r--r--api/gui/CMakeLists.txt27
1 files changed, 13 insertions, 14 deletions
diff --git a/api/gui/CMakeLists.txt b/api/gui/CMakeLists.txt
index deae735f..ad116a43 100644
--- a/api/gui/CMakeLists.txt
+++ b/api/gui/CMakeLists.txt
@@ -1,17 +1,17 @@
project(MultiMC_gui LANGUAGES CXX)
set(GUI_SOURCES
- DesktopServices.h
- DesktopServices.cpp
+ DesktopServices.h
+ DesktopServices.cpp
- # Icons
- icons/MMCIcon.h
- icons/MMCIcon.cpp
- icons/IconList.h
- icons/IconList.cpp
+ # Icons
+ icons/MMCIcon.h
+ icons/MMCIcon.cpp
+ icons/IconList.h
+ icons/IconList.cpp
- SkinUtils.cpp
- SkinUtils.h
+ SkinUtils.cpp
+ SkinUtils.h
)
################################ COMPILE ################################
@@ -21,15 +21,14 @@ set_target_properties(MultiMC_gui PROPERTIES CXX_VISIBILITY_PRESET hidden VISIBI
generate_export_header(MultiMC_gui)
# Link
-target_link_libraries(MultiMC_gui MultiMC_iconfix MultiMC_logic)
-qt5_use_modules(MultiMC_gui Gui)
+target_link_libraries(MultiMC_gui MultiMC_iconfix MultiMC_logic Qt5::Gui)
# Mark and export headers
target_include_directories(MultiMC_gui PUBLIC "${CMAKE_CURRENT_BINARY_DIR}" "${CMAKE_CURRENT_SOURCE_DIR}")
# Install it
install(
- TARGETS MultiMC_gui
- RUNTIME DESTINATION ${LIBRARY_DEST_DIR}
- LIBRARY DESTINATION ${LIBRARY_DEST_DIR}
+ TARGETS MultiMC_gui
+ RUNTIME DESTINATION ${LIBRARY_DEST_DIR}
+ LIBRARY DESTINATION ${LIBRARY_DEST_DIR}
) \ No newline at end of file