summaryrefslogtreecommitdiffstats
path: root/libraries/pack200/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2018-01-22 04:28:07 +0100
committerPetr Mrázek <peterix@gmail.com>2018-01-27 02:00:20 +0100
commit166e5a03d63e0b522876bfc072f26f213d5a3a62 (patch)
tree73b9ec9ab09e4a3fcf5c2c0b0ce6568b0b3e0b9b /libraries/pack200/CMakeLists.txt
parent0c2e2094ee96ebe8764dd977bd0b5eb254579dcc (diff)
downloadMultiMC-166e5a03d63e0b522876bfc072f26f213d5a3a62.tar
MultiMC-166e5a03d63e0b522876bfc072f26f213d5a3a62.tar.gz
MultiMC-166e5a03d63e0b522876bfc072f26f213d5a3a62.tar.lz
MultiMC-166e5a03d63e0b522876bfc072f26f213d5a3a62.tar.xz
MultiMC-166e5a03d63e0b522876bfc072f26f213d5a3a62.zip
NOISSUE rearrange build system
* Added install commands to the libraries instead of force installing files * Most of the application cmake stuff moved to top level * RPATH should now be set/cleared correctly * Contains a fix for GH-1780
Diffstat (limited to 'libraries/pack200/CMakeLists.txt')
-rw-r--r--libraries/pack200/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/libraries/pack200/CMakeLists.txt b/libraries/pack200/CMakeLists.txt
index 359445d2..c9e05fbd 100644
--- a/libraries/pack200/CMakeLists.txt
+++ b/libraries/pack200/CMakeLists.txt
@@ -37,6 +37,9 @@ target_link_libraries(MultiMC_unpack200 ${ZLIB_LIBRARIES})
set_target_properties(MultiMC_unpack200 PROPERTIES CXX_VISIBILITY_PRESET hidden VISIBILITY_INLINES_HIDDEN 1)
generate_export_header(MultiMC_unpack200)
+# Install it
+install(TARGETS MultiMC_unpack200 DESTINATION ${LIBRARY_DEST_DIR})
+
if(PACK200_BUILD_BINARY)
add_executable(anti200 anti200.cpp)
target_link_libraries(anti200 MultiMC_unpack200)