summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2014-06-29 19:59:08 +0200
committerPetr Mrázek <peterix@gmail.com>2014-06-29 19:59:08 +0200
commit5179aed3a066dfc9885a75d36a0e64c48aa448f7 (patch)
treeec0c656f06ca923b86a9025c0904cfc7c7f81845 /CMakeLists.txt
parent77de2d1e5472051cd05857dc4304bdc9ad77e36d (diff)
downloadMultiMC-5179aed3a066dfc9885a75d36a0e64c48aa448f7.tar
MultiMC-5179aed3a066dfc9885a75d36a0e64c48aa448f7.tar.gz
MultiMC-5179aed3a066dfc9885a75d36a0e64c48aa448f7.tar.lz
MultiMC-5179aed3a066dfc9885a75d36a0e64c48aa448f7.tar.xz
MultiMC-5179aed3a066dfc9885a75d36a0e64c48aa448f7.zip
Separate page dialog into a page container and a dialog.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7789db3..16026015 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -291,10 +291,7 @@ SET(MULTIMC_SOURCES
gui/ConsoleWindow.h
gui/ConsoleWindow.cpp
- # GUI - page dialog and pages
- gui/pagedialog/PageDialog.cpp
- gui/pagedialog/PageDialog.h
- gui/pagedialog/PageDialog_p.h
+ # GUI - page dialog pages
gui/pages/VersionPage.cpp
gui/pages/VersionPage.h
gui/pages/TexturePackPage.h
@@ -337,6 +334,8 @@ SET(MULTIMC_SOURCES
gui/dialogs/NewInstanceDialog.h
gui/dialogs/NotificationDialog.cpp
gui/dialogs/NotificationDialog.h
+ gui/pagedialog/PageDialog.cpp
+ gui/pagedialog/PageDialog.h
gui/dialogs/ProgressDialog.cpp
gui/dialogs/ProgressDialog.h
gui/dialogs/SettingsDialog.cpp
@@ -360,6 +359,9 @@ SET(MULTIMC_SOURCES
gui/widgets/MCModInfoFrame.h
gui/widgets/ModListView.cpp
gui/widgets/ModListView.h
+ gui/widgets/PageContainer.cpp
+ gui/widgets/PageContainer.h
+ gui/widgets/PageContainer_p.h
gui/widgets/ServerStatus.cpp
gui/widgets/ServerStatus.h
gui/widgets/VersionListView.cpp