summaryrefslogtreecommitdiffstats
path: root/src/threads/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/threads/Makefile.am')
-rw-r--r--src/threads/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/threads/Makefile.am b/src/threads/Makefile.am
new file mode 100644
index 0000000..221bddf
--- /dev/null
+++ b/src/threads/Makefile.am
@@ -0,0 +1,11 @@
+AM_CPPFLAGS = -Wall -I$(top_srcdir)/src
+
+noinst_LIBRARIES = libthread.a
+
+libthread_a_SOURCES =\
+ thread.cpp\
+ mutex.cpp\
+ sema.cpp\
+ thread.h\
+ mutex.h\
+ sema.h