summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt103
1 files changed, 103 insertions, 0 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
new file mode 100644
index 0000000..16d1c3a
--- /dev/null
+++ b/src/gui/CMakeLists.txt
@@ -0,0 +1,103 @@
+project(twinkle-gui)
+
+add_definitions(-DQT3_SUPPORT)
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+qt4_wrap_ui(
+ twinkle_UIS
+ addresscardform.ui
+ authenticationform.ui
+ buddyform.ui
+ deregisterform.ui
+ diamondcardprofileform.ui
+ dtmfform.ui
+ getaddressform.ui
+ getprofilenameform.ui
+ historyform.ui
+ inviteform.ui
+ logviewform.ui
+ messageform.ui
+ mphoneform.ui
+ numberconversionform.ui
+ redirectform.ui
+ selectnicform.ui
+ selectprofileform.ui
+ selectuserform.ui
+ sendfileform.ui
+ srvredirectform.ui
+ syssettingsform.ui
+ termcapform.ui
+ transferform.ui
+ userprofileform.ui
+ wizardform.ui
+)
+
+qt4_add_resources(twinkle_QRC icons.qrc)
+
+qt4_wrap_cpp(twinkle_MOC
+ gui.h
+ dtmfform.h
+ deregisterform.h
+ logviewform.h
+ numberconversionform.h
+ getprofilenameform.h
+ historylistview.h
+ freedesksystray.h
+ twinklesystray.h
+ address_finder.h
+ qt_translator.h
+ core_strings.h
+ addresslistviewitem.h
+ yesnodialog.h
+ command_args.h
+ messageformview.h
+ buddylistview.h
+ textbrowsernoautolink.h
+ twinkleapplication.h
+)
+
+set(TWINKLE_GUI-SRCS
+ address_finder.cpp
+ addresslistviewitem.cpp
+ buddylistview.cpp
+ deregisterform.cpp
+ dtmfform.cpp
+ freedesksystray.cpp
+ getprofilenameform.cpp
+ gui.cpp
+ historylistview.cpp
+ logviewform.cpp
+ main.cpp
+ messageformview.cpp
+ numberconversionform.cpp
+ twinkleapplication.cpp
+ twinklesystray.cpp
+ yesnodialog.cpp
+
+ $<TARGET_OBJECTS:libtwinkle>
+ $<TARGET_OBJECTS:libtwinkle-audio>
+ $<TARGET_OBJECTS:libtwinkle-gsm>
+ $<TARGET_OBJECTS:libtwinkle-audits>
+ $<TARGET_OBJECTS:libtwinkle-im>
+ $<TARGET_OBJECTS:libtwinkle-mwi>
+ $<TARGET_OBJECTS:libtwinkle-parser>
+ $<TARGET_OBJECTS:libtwinkle-patterns>
+ $<TARGET_OBJECTS:libtwinkle-presence>
+ $<TARGET_OBJECTS:libtwinkle-sdp>
+ $<TARGET_OBJECTS:libtwinkle-sockets>
+ $<TARGET_OBJECTS:libtwinkle-stun>
+ $<TARGET_OBJECTS:libtwinkle-threads>
+ $<TARGET_OBJECTS:libtwinkle-utils>
+ ${twinkle_UIS}
+ ${twinkle_QRC}
+ ${twinkle_MOC}
+)
+
+add_executable(twinkle ${TWINKLE_GUI-SRCS})
+target_link_libraries(twinkle -lpthread -lresolv ${LibMagic_LIBRARY} ${LIBXML2_LIBRARIES}
+ ${Readline_LIBRARY} ${ILBC_LIBRARIES} ${SPEEX_LIBRARIES} ${ZRTPCPP_LIBRARIES}
+ ${CCRTP_LIBRARIES} ${COMMONCPP_LIBRARIES} ${UCOMMON_LIBRARIES} ${LIBSNDFILE_LIBRARY}
+ ${Boost_LIBRARIES} ${QT_LIBRARIES})
+
+install(TARGETS twinkle DESTINATION bin)