summaryrefslogtreecommitdiffstats
path: root/src/threads/Makefile.am
diff options
context:
space:
mode:
authorMichal Kubecek <mkubecek@suse.cz>2015-04-13 09:21:39 +0200
committerMichal Kubecek <mkubecek@suse.cz>2015-04-13 09:21:39 +0200
commite2bc6f4153813cc570ae814c8ddb74628009b488 (patch)
treea40b171be1d859c2232ccc94f758010f9ae54d3c /src/threads/Makefile.am
downloadtwinkle-e2bc6f4153813cc570ae814c8ddb74628009b488.tar
twinkle-e2bc6f4153813cc570ae814c8ddb74628009b488.tar.gz
twinkle-e2bc6f4153813cc570ae814c8ddb74628009b488.tar.lz
twinkle-e2bc6f4153813cc570ae814c8ddb74628009b488.tar.xz
twinkle-e2bc6f4153813cc570ae814c8ddb74628009b488.zip
initial checkin
Check in contents of upstream 1.4.2 tarball, exclude generated files.
Diffstat (limited to 'src/threads/Makefile.am')
-rw-r--r--src/threads/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/threads/Makefile.am b/src/threads/Makefile.am
new file mode 100644
index 0000000..221bddf
--- /dev/null
+++ b/src/threads/Makefile.am
@@ -0,0 +1,11 @@
+AM_CPPFLAGS = -Wall -I$(top_srcdir)/src
+
+noinst_LIBRARIES = libthread.a
+
+libthread_a_SOURCES =\
+ thread.cpp\
+ mutex.cpp\
+ sema.cpp\
+ thread.h\
+ mutex.h\
+ sema.h