summaryrefslogtreecommitdiffstats
path: root/src/presence/Makefile.am
diff options
context:
space:
mode:
authorMichal Kubecek <mkubecek@suse.cz>2015-04-13 09:21:39 +0200
committerMichal Kubecek <mkubecek@suse.cz>2015-04-13 09:21:39 +0200
commite2bc6f4153813cc570ae814c8ddb74628009b488 (patch)
treea40b171be1d859c2232ccc94f758010f9ae54d3c /src/presence/Makefile.am
downloadtwinkle-e2bc6f4153813cc570ae814c8ddb74628009b488.tar
twinkle-e2bc6f4153813cc570ae814c8ddb74628009b488.tar.gz
twinkle-e2bc6f4153813cc570ae814c8ddb74628009b488.tar.lz
twinkle-e2bc6f4153813cc570ae814c8ddb74628009b488.tar.xz
twinkle-e2bc6f4153813cc570ae814c8ddb74628009b488.zip
initial checkin
Check in contents of upstream 1.4.2 tarball, exclude generated files.
Diffstat (limited to 'src/presence/Makefile.am')
-rw-r--r--src/presence/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/presence/Makefile.am b/src/presence/Makefile.am
new file mode 100644
index 0000000..17caf93
--- /dev/null
+++ b/src/presence/Makefile.am
@@ -0,0 +1,17 @@
+AM_CPPFLAGS = -Wall $(CCRTP_CFLAGS) $(XML2_CFLAGS) -I$(top_srcdir)/src
+
+noinst_LIBRARIES = libpresence.a
+
+libpresence_a_SOURCES =\
+ buddy.cpp\
+ pidf_body.cpp\
+ presence_dialog.cpp\
+ presence_epa.cpp\
+ presence_state.cpp\
+ presence_subscription.cpp\
+ buddy.h\
+ pidf_body.h\
+ presence_dialog.h\
+ presence_epa.h\
+ presence_state.h\
+ presence_subscription.h