summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorFrédéric Brière <fbriere@fbriere.net>2019-07-12 19:01:41 -0400
committerFrédéric Brière <fbriere@fbriere.net>2019-07-13 13:54:11 -0400
commit1e9f091f39a32193b0671e9dfbfb657dd45fec3e (patch)
treef681d42a408178bcdf31f784a27d027ec6b0b291 /src/gui/CMakeLists.txt
parent05082ae12051821b1d969e6672d9e4e5afe1bc07 (diff)
downloadtwinkle-1e9f091f39a32193b0671e9dfbfb657dd45fec3e.tar
twinkle-1e9f091f39a32193b0671e9dfbfb657dd45fec3e.tar.gz
twinkle-1e9f091f39a32193b0671e9dfbfb657dd45fec3e.tar.lz
twinkle-1e9f091f39a32193b0671e9dfbfb657dd45fec3e.tar.xz
twinkle-1e9f091f39a32193b0671e9dfbfb657dd45fec3e.zip
Add an option to prevent an idle session while a call is in progress
Having the session marked as idle while a call is in progress could trigger certain actions (such as locking the screen, logging out automatically, or suspending the system) which could be undesirable in this situation. Closes #123
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index fca7d2e..f49c237 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -52,6 +52,9 @@ qt5_add_translation(twinkle_LANG
)
set(qt_LIBS Qt5::Widgets Qt5::Quick)
+if (WITH_DBUS)
+ list(APPEND qt_LIBS Qt5::DBus)
+endif (WITH_DBUS)
set(CMAKE_AUTOMOC ON)
@@ -93,12 +96,17 @@ set(TWINKLE_GUI-SRCS
textbrowsernoautolink.cpp
osd.cpp
incoming_call_popup.cpp
+ idlesession_manager.cpp
${twinkle_OBJS}
${twinkle_UIS}
${twinkle_QRC}
${twinkle_LANG}
)
+if (WITH_DBUS)
+ list(APPEND TWINKLE_GUI-SRCS
+ idlesession_inhibitor.cpp)
+endif (WITH_DBUS)
add_executable(twinkle ${TWINKLE_GUI-SRCS})
target_link_libraries(twinkle ${twinkle_LIBS} ${qt_LIBS})