summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Colberg <peter@colberg.org>2015-12-30 17:27:41 -0500
committerPeter Colberg <peter@colberg.org>2015-12-30 17:27:41 -0500
commitcd2ed3242770f4bad6fbae133837b98cab6fcea5 (patch)
treede45037fbfd69b1f0e7b38c580be840542264a9b /CMakeLists.txt
parentbf672d530aeb01d92022f290a0daf005bdf0bbe1 (diff)
downloadtwinkle-cd2ed3242770f4bad6fbae133837b98cab6fcea5.tar
twinkle-cd2ed3242770f4bad6fbae133837b98cab6fcea5.tar.gz
twinkle-cd2ed3242770f4bad6fbae133837b98cab6fcea5.tar.lz
twinkle-cd2ed3242770f4bad6fbae133837b98cab6fcea5.tar.xz
twinkle-cd2ed3242770f4bad6fbae133837b98cab6fcea5.zip
Include <sys/socket.h> when detecting <linux/errqueue.h>
This is consistent with the actual use in `src/sockets/socket.cpp`.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 86b34bd..0117fdb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -131,7 +131,7 @@ endif (WITH_GSM)
check_include_file(unistd.h HAVE_UNISTD_H)
check_include_file(linux/types.h HAVE_LINUX_TYPES_H)
-check_include_files("sys/time.h;linux/errqueue.h" HAVE_LINUX_ERRQUEUE_H)
+check_include_files("sys/socket.h;linux/errqueue.h" HAVE_LINUX_ERRQUEUE_H)
set(datadir "${CMAKE_INSTALL_PREFIX}/share/twinkle")
configure_file(twinkle_config.h.in twinkle_config.h)