summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLubos Dolezel <lubos@dolezel.info>2015-06-01 11:30:01 +0200
committerLubos Dolezel <lubos@dolezel.info>2015-06-01 11:31:22 +0200
commit545703d60acb8b0245e3d79e5dfd7171ca10c572 (patch)
treec7a54f533a0592fe4fa00013eff599463cdc8200 /CMakeLists.txt
parenta89783c705ddb30ffc3b1e3c87b0761f60c33022 (diff)
downloadtwinkle-545703d60acb8b0245e3d79e5dfd7171ca10c572.tar
twinkle-545703d60acb8b0245e3d79e5dfd7171ca10c572.tar.gz
twinkle-545703d60acb8b0245e3d79e5dfd7171ca10c572.tar.lz
twinkle-545703d60acb8b0245e3d79e5dfd7171ca10c572.tar.xz
twinkle-545703d60acb8b0245e3d79e5dfd7171ca10c572.zip
Added initial CMakeLists.txt, searching for dependencies (zrtp, ilbc, speex)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f698e29
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,40 @@
+project(twinkle)
+
+cmake_minimum_required(VERSION 2.6.0 FATAL_ERROR)
+
+OPTION(WITH_ZRTP "Enable ZRTP encrypted calls" OFF)
+OPTION(WITH_SPEEX "Enable the Speex codec" OFF)
+OPTION(WITH_ILBC "Enable the iLBC codec" OFF)
+
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
+find_package(Qt4 REQUIRED)
+
+if (WITH_ZRTP)
+ find_package(Zrtpcpp)
+
+ if (ZRTPCPP_FOUND)
+ message(STATUS "libzrtpcpp OK")
+ else (ZRTPCPP_FOUND)
+ message(FATAL_ERROR "libzrtpcpp not found!")
+ endif (ZRTPCPP_FOUND)
+endif (WITH_ZRTP)
+
+if (WITH_SPEEX)
+ find_package(Speex)
+
+ if (SPEEX_FOUND)
+ message(STATUS "Speex OK")
+ else (SPEEX_FOUND)
+ message(FATAL_ERROR "Speex not found!")
+ endif (SPEEX_FOUND)
+endif (WITH_SPEEX)
+
+if (WITH_ILBC)
+ find_package(Ilbc)
+
+ if (ILBC_FOUND)
+ message(STATUS "iLBC OK")
+ else (ILBC_FOUND)
+ message(FATAL_ERROR "iLBC not found!")
+ endif (ILBC_FOUND)
+endif (WITH_ILBC)