summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Colberg <peter@colberg.org>2015-12-29 00:29:42 -0500
committerPeter Colberg <peter@colberg.org>2015-12-29 00:29:42 -0500
commit4803e6a493f9233567f6fe6923facafd0495e7d7 (patch)
tree6056aa24807d0723ee4c7c11711e20a8feea6597 /CMakeLists.txt
parent3f17756e67e8da2e93f796ca6e7c1bb61b7b00b5 (diff)
downloadtwinkle-4803e6a493f9233567f6fe6923facafd0495e7d7.tar
twinkle-4803e6a493f9233567f6fe6923facafd0495e7d7.tar.gz
twinkle-4803e6a493f9233567f6fe6923facafd0495e7d7.tar.lz
twinkle-4803e6a493f9233567f6fe6923facafd0495e7d7.tar.xz
twinkle-4803e6a493f9233567f6fe6923facafd0495e7d7.zip
Add option WITH_GSM to use external gsm library
This permits distributions to build against a packaged gsm library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d41f749..d8cd1fc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ OPTION(WITH_DIAMONDCARD "Enable Diamondcard integration" OFF)
OPTION(WITH_QT4 "Enable Qt 4 GUI" OFF)
OPTION(WITH_QT5 "Enable Qt 5 GUI" OFF)
OPTION(WITH_G729 "Enable G.729A support" OFF)
+OPTION(WITH_GSM "Use external GSM library" OFF)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
@@ -114,6 +115,18 @@ if (WITH_G729)
endif (G729_FOUND)
endif (WITH_G729)
+if (WITH_GSM)
+ find_package(Gsm)
+
+ if (GSM_FOUND)
+ message(STATUS "gsm OK")
+ set(HAVE_GSM TRUE)
+
+ include_directories(${GSM_INCLUDE_DIR})
+ else (GSM_FOUND)
+ message(FATAL_ERROR "gsm not found!")
+ endif (GSM_FOUND)
+endif (WITH_GSM)
check_include_file(unistd.h HAVE_UNISTD_H)
check_include_file(linux/types.h HAVE_LINUX_TYPES_H)