summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrédéric Brière <fbriere@fbriere.net>2019-07-12 19:01:41 -0400
committerFrédéric Brière <fbriere@fbriere.net>2019-07-13 13:54:11 -0400
commit1e9f091f39a32193b0671e9dfbfb657dd45fec3e (patch)
treef681d42a408178bcdf31f784a27d027ec6b0b291 /CMakeLists.txt
parent05082ae12051821b1d969e6672d9e4e5afe1bc07 (diff)
downloadtwinkle-1e9f091f39a32193b0671e9dfbfb657dd45fec3e.tar
twinkle-1e9f091f39a32193b0671e9dfbfb657dd45fec3e.tar.gz
twinkle-1e9f091f39a32193b0671e9dfbfb657dd45fec3e.tar.lz
twinkle-1e9f091f39a32193b0671e9dfbfb657dd45fec3e.tar.xz
twinkle-1e9f091f39a32193b0671e9dfbfb657dd45fec3e.zip
Add an option to prevent an idle session while a call is in progress
Having the session marked as idle while a call is in progress could trigger certain actions (such as locking the screen, logging out automatically, or suspending the system) which could be undesirable in this situation. Closes #123
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5315383..6376a29 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,12 +6,15 @@ set(PRODUCT_VERSION "1.10.2")
set(PRODUCT_DATE "February 14, 2018")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+include(CMakeDependentOption)
+
OPTION(WITH_ZRTP "Enable ZRTP encrypted calls" OFF)
OPTION(WITH_SPEEX "Enable the Speex codec" OFF)
OPTION(WITH_ILBC "Enable the iLBC codec" OFF)
OPTION(WITH_ALSA "Enable ALSA support" ON)
OPTION(WITH_DIAMONDCARD "Enable Diamondcard integration" OFF)
OPTION(WITH_QT5 "Enable Qt 5 GUI" ON)
+CMAKE_DEPENDENT_OPTION(WITH_DBUS "Enable use of QtDBus (GUI only)" ON "WITH_QT5" OFF)
OPTION(WITH_G729 "Enable G.729A support" OFF)
OPTION(WITH_GSM "Use external GSM library" OFF)
@@ -37,6 +40,11 @@ if (WITH_QT5)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Widgets_EXECUTABLE_COMPILE_FLAGS} ${Qt5Quick_EXECUTABLE_COMPILE_FLAGS}")
include_directories(${Qt5Widgets_INCLUDES} ${Qt5Quick_INCLUDES})
add_definitions(${Qt5Widgets_DEFINITIONS} ${Qt5Quick_DEFINITIONS})
+
+ if (WITH_DBUS)
+ find_package(Qt5DBus REQUIRED)
+ set(HAVE_DBUS TRUE)
+ endif (WITH_DBUS)
endif (WITH_QT5)
include_directories(${LIBXML2_INCLUDE_DIR})