summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLuboš Doležel <lubos@dolezel.info>2020-02-23 09:50:24 +0100
committerGitHub <noreply@github.com>2020-02-23 09:50:24 +0100
commit188bd0606473fee9d7a09e17b9980f7a16d4dc31 (patch)
treee3147fbe8243a91893e2e31cf1b7246869604430 /CMakeLists.txt
parente9e1b86afd75cb55c90bc6ce58fc9c2d0c025a3f (diff)
parent3d9fb0ac7490620a49a400b77ab8f851cdd4fcf5 (diff)
downloadtwinkle-188bd0606473fee9d7a09e17b9980f7a16d4dc31.tar
twinkle-188bd0606473fee9d7a09e17b9980f7a16d4dc31.tar.gz
twinkle-188bd0606473fee9d7a09e17b9980f7a16d4dc31.tar.lz
twinkle-188bd0606473fee9d7a09e17b9980f7a16d4dc31.tar.xz
twinkle-188bd0606473fee9d7a09e17b9980f7a16d4dc31.zip
Merge pull request #154 from fbriere/feature/inhibit-idle-session
Add an option to prevent an idle session while a call is in progress
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 127621a..1dafe55 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,12 +10,15 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
set_directory_properties(PROPERTIES
COMPILE_DEFINITIONS $<$<OR:$<CONFIG:>,$<CONFIG:Debug>>:DEBUG>)
+include(CMakeDependentOption)
+
OPTION(WITH_ZRTP "Enable ZRTP encrypted calls" OFF)
OPTION(WITH_SPEEX "Enable the Speex codec" OFF)
OPTION(WITH_ILBC "Enable the iLBC codec" OFF)
OPTION(WITH_ALSA "Enable ALSA support" ON)
OPTION(WITH_DIAMONDCARD "Enable Diamondcard integration" OFF)
OPTION(WITH_QT5 "Enable Qt 5 GUI" ON)
+CMAKE_DEPENDENT_OPTION(WITH_DBUS "Enable use of QtDBus (GUI only)" ON "WITH_QT5" OFF)
OPTION(WITH_G729 "Enable G.729A support" OFF)
OPTION(WITH_GSM "Use external GSM library" OFF)
@@ -45,6 +48,11 @@ if (WITH_QT5)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Widgets_EXECUTABLE_COMPILE_FLAGS} ${Qt5Quick_EXECUTABLE_COMPILE_FLAGS}")
include_directories(${Qt5Widgets_INCLUDES} ${Qt5Quick_INCLUDES})
add_definitions(${Qt5Widgets_DEFINITIONS} ${Qt5Quick_DEFINITIONS})
+
+ if (WITH_DBUS)
+ find_package(Qt5DBus REQUIRED)
+ set(HAVE_DBUS TRUE)
+ endif (WITH_DBUS)
endif (WITH_QT5)
include_directories(${LIBXML2_INCLUDE_DIR})