summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrédéric Brière <fbriere@fbriere.net>2016-09-29 10:34:13 -0400
committerFrédéric Brière <fbriere@fbriere.net>2016-10-03 21:29:03 -0400
commit106e76243b1c703f1dace53727efa8be01b166dd (patch)
tree99bfdeee31bc8bb9fc395470d054adf35e078df6 /CMakeLists.txt
parent72d9427762fb077239f6121b4320f76d63dbbc51 (diff)
downloadtwinkle-106e76243b1c703f1dace53727efa8be01b166dd.tar
twinkle-106e76243b1c703f1dace53727efa8be01b166dd.tar.gz
twinkle-106e76243b1c703f1dace53727efa8be01b166dd.tar.lz
twinkle-106e76243b1c703f1dace53727efa8be01b166dd.tar.xz
twinkle-106e76243b1c703f1dace53727efa8be01b166dd.zip
Have CMake check for Ucommon before Commoncpp
Failure to install uCommon C++ will result in the message "Could NOT find commoncpp development files". This could be confusing, as "commoncpp" may ambiguously refer to either Common C++ (commoncpp2) or uCommon C++ (libcommoncpp). By checking for Ucommon first, the resulting message will be: "Could NOT find ucommon development files", which is clearly unambiguous.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 401fe18..0acff4a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,9 +26,9 @@ find_package(LibSndfile REQUIRED)
find_package(Readline REQUIRED)
find_package(BISON REQUIRED)
find_package(FLEX REQUIRED)
+find_package(Ucommon REQUIRED)
find_package(Commoncpp REQUIRED)
find_package(Ccrtp REQUIRED)
-find_package(Ucommon REQUIRED)
if (WITH_QT5)
find_package(Qt5Widgets REQUIRED)