summaryrefslogtreecommitdiffstats
path: root/toolkit/library/rust/shared/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/library/rust/shared/Cargo.toml')
-rw-r--r--toolkit/library/rust/shared/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/toolkit/library/rust/shared/Cargo.toml b/toolkit/library/rust/shared/Cargo.toml
new file mode 100644
index 000000000..07e735755
--- /dev/null
+++ b/toolkit/library/rust/shared/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "gkrust-shared"
+version = "0.1.0"
+authors = ["nobody@mozilla.org"]
+license = "MPL-2.0"
+description = "Shared Rust code for libxul"
+
+[dependencies]
+mp4parse_capi = { path = "../../../../media/libstagefright/binding/mp4parse_capi" }
+nsstring = { path = "../../../../xpcom/rust/nsstring" }
+rust_url_capi = { path = "../../../../netwerk/base/rust-url-capi" }
+
+[lib]
+path = "lib.rs"
+test = false
+doctest = false
+bench = false
+doc = false
+plugin = false
+harness = false