summaryrefslogtreecommitdiffstats
path: root/toolkit/library/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/library/rust/Cargo.toml')
-rw-r--r--toolkit/library/rust/Cargo.toml37
1 files changed, 0 insertions, 37 deletions
diff --git a/toolkit/library/rust/Cargo.toml b/toolkit/library/rust/Cargo.toml
deleted file mode 100644
index c41fd43c6..000000000
--- a/toolkit/library/rust/Cargo.toml
+++ /dev/null
@@ -1,37 +0,0 @@
-[package]
-name = "gkrust"
-version = "0.1.0"
-authors = ["nobody@mozilla.org"]
-license = "MPL-2.0"
-description = "Rust code for libxul"
-
-[dependencies]
-gkrust-shared = { path = "shared" }
-
-[lib]
-path = "lib.rs"
-crate-type = ["staticlib"]
-test = false
-doctest = false
-bench = false
-doc = false
-plugin = false
-harness = false
-
-# Explicitly specify what our profiles use.
-[profile.dev]
-opt-level = 1
-debug = true
-rpath = false
-lto = false
-debug-assertions = true
-codegen-units = 1
-panic = "abort"
-
-[profile.release]
-opt-level = 2
-debug = true
-rpath = false
-lto = true
-debug-assertions = false
-panic = "abort"