summaryrefslogtreecommitdiffstats
path: root/toolkit/library/gtest/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/library/gtest/rust/Cargo.toml')
-rw-r--r--toolkit/library/gtest/rust/Cargo.toml42
1 files changed, 0 insertions, 42 deletions
diff --git a/toolkit/library/gtest/rust/Cargo.toml b/toolkit/library/gtest/rust/Cargo.toml
deleted file mode 100644
index f1a52aa4f..000000000
--- a/toolkit/library/gtest/rust/Cargo.toml
+++ /dev/null
@@ -1,42 +0,0 @@
-[package]
-name = "gkrust-gtest"
-version = "0.1.0"
-authors = ["nobody@mozilla.org"]
-license = "MPL-2.0"
-description = "Testing code for libgkrust"
-
-[dependencies]
-gkrust-shared = { path = "../../rust/shared" }
-
-[lib]
-path = "lib.rs"
-crate-type = ["staticlib"]
-test = false
-doctest = false
-bench = false
-doc = false
-plugin = false
-harness = false
-
-# Explicitly specify what our profiles use.
-[profile.dev]
-opt-level = 1
-debug = true
-rpath = false
-lto = false
-debug-assertions = true
-codegen-units = 1
-panic = "abort"
-
-[profile.release]
-opt-level = 2
-debug = true
-rpath = false
-# This would normally be 'true' for release configurations, but using LTO on
-# rul-gtest causes link failures due to symbols also being found in libxul's
-# librul.a. But LTO'ing things here is not crucial and not LTO'ing things
-# enables us to link libxul-gtest, so we leave it turned off.
-lto = false
-debug-assertions = false
-codegen-units = 1
-panic = "abort"