summaryrefslogtreecommitdiffstats
path: root/toolkit/crashreporter/google-breakpad/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/crashreporter/google-breakpad/configure.ac')
-rw-r--r--toolkit/crashreporter/google-breakpad/configure.ac204
1 files changed, 204 insertions, 0 deletions
diff --git a/toolkit/crashreporter/google-breakpad/configure.ac b/toolkit/crashreporter/google-breakpad/configure.ac
new file mode 100644
index 000000000..23195b7d3
--- /dev/null
+++ b/toolkit/crashreporter/google-breakpad/configure.ac
@@ -0,0 +1,204 @@
+# Copyright (c) 2006, Google Inc.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above
+# copyright notice, this list of conditions and the following disclaimer
+# in the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Google Inc. nor the names of its
+# contributors may be used to endorse or promote products derived from
+# this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+AC_PREREQ(2.57)
+
+AC_INIT(breakpad, 0.1, google-breakpad-dev@googlegroups.com)
+dnl Sanity check: the argument is just a file that should exist.
+AC_CONFIG_SRCDIR(README.md)
+AC_CONFIG_AUX_DIR(autotools)
+AC_CONFIG_MACRO_DIR([m4])
+AC_CANONICAL_HOST
+
+AM_INIT_AUTOMAKE(subdir-objects tar-ustar 1.11.1)
+AM_CONFIG_HEADER(src/config.h)
+AM_MAINTAINER_MODE
+
+AM_PROG_AR
+AM_PROG_AS
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_PROG_CPP
+AC_PROG_CXX
+AC_PROG_RANLIB
+AM_CONDITIONAL(GCC, test "$GCC" = yes) # let the Makefile know if we're gcc
+
+dnl This must come before all the feature tests below.
+AC_ARG_ENABLE(m32,
+ AS_HELP_STRING([--enable-m32],
+ [Compile/build with -m32]
+ [(default is no)]),
+ [case "${enableval}" in
+ yes)
+ CFLAGS="${CFLAGS} -m32"
+ CXXFLAGS="${CXXFLAGS} -m32"
+ usem32=true
+ ;;
+ no)
+ usem32=false
+ ;;
+ *)
+ AC_MSG_ERROR(bad value ${enableval} for --enable-m32)
+ ;;
+ esac],
+ [usem32=false])
+
+AC_HEADER_STDC
+AC_SYS_LARGEFILE
+m4_include(m4/ax_pthread.m4)
+AX_PTHREAD
+AC_CHECK_HEADERS([a.out.h])
+
+m4_include(m4/ax_cxx_compile_stdcxx.m4)
+AX_CXX_COMPILE_STDCXX(11, noext, mandatory)
+
+# Only build Linux client libs when compiling for Linux
+case $host in
+ *-*-linux* | *-android* )
+ LINUX_HOST=true
+ ;;
+esac
+AM_CONDITIONAL(LINUX_HOST, test x$LINUX_HOST = xtrue)
+
+# Only use Android support headers when compiling for Android
+case $host in
+ *-android*)
+ ANDROID_HOST=true
+ ;;
+esac
+AM_CONDITIONAL(ANDROID_HOST, test x$ANDROID_HOST = xtrue)
+
+# Some tools (like mac ones) only support x86 currently.
+case $host_cpu in
+ i?86|x86_64)
+ X86_HOST=true
+ ;;
+esac
+AM_CONDITIONAL(X86_HOST, test x$X86_HOST = xtrue)
+
+AC_ARG_ENABLE(processor,
+ AS_HELP_STRING([--disable-processor],
+ [Don't build processor library]
+ [(default is no)]),
+ [case "${enableval}" in
+ yes)
+ disable_processor=false
+ ;;
+ no)
+ disable_processor=true
+ ;;
+ *)
+ AC_MSG_ERROR(bad value ${enableval} for --disable-processor)
+ ;;
+ esac],
+ [disable_processor=false])
+AM_CONDITIONAL(DISABLE_PROCESSOR, test x$disable_processor = xtrue)
+
+AC_ARG_ENABLE(tools,
+ AS_HELP_STRING([--disable-tools],
+ [Don't build tool binaries]
+ [(default is no)]),
+ [case "${enableval}" in
+ yes)
+ disable_tools=false
+ ;;
+ no)
+ disable_tools=true
+ ;;
+ *)
+ AC_MSG_ERROR(bad value ${enableval} for --disable-tools)
+ ;;
+ esac],
+ [disable_tools=false])
+AM_CONDITIONAL(DISABLE_TOOLS, test x$disable_tools = xtrue)
+
+if test x$LINUX_HOST = xfalse -a x$disable_processor = xtrue -a x$disable_tools = xtrue; then
+ AC_MSG_ERROR([--disable-processor and --disable-tools were specified, and not building for Linux. Nothing to build!])
+fi
+
+AC_ARG_ENABLE(system-test-libs,
+ AS_HELP_STRING([--enable-system-test-libs],
+ [Use gtest/gmock/etc... from the system instead ]
+ [of the local copies (default is local)]),
+ [case "${enableval}" in
+ yes)
+ system_test_libs=true
+ ;;
+ no)
+ system_test_libs=false
+ ;;
+ *)
+ AC_MSG_ERROR(bad value ${enableval} for --enable-system-test-libs)
+ ;;
+ esac],
+ [system_test_libs=false])
+AM_CONDITIONAL(SYSTEM_TEST_LIBS, test x$system_test_libs = xtrue)
+
+AC_ARG_VAR([GMOCK_CONFIG], [Path to gmock-config script])
+AC_ARG_VAR([GMOCK_CFLAGS], [Compiler flags for gmock])
+AC_ARG_VAR([GMOCK_LIBS], [Linker flags for gmock])
+AC_ARG_VAR([GTEST_CONFIG], [Path to gtest-config script])
+AC_ARG_VAR([GTEST_CFLAGS], [Compiler flags for gtest])
+AC_ARG_VAR([GTEST_LIBS], [Linker flags for gtest])
+if test x$system_test_libs = xtrue; then
+ AC_CHECK_TOOL([GMOCK_CONFIG], [gmock-config])
+ AC_CHECK_TOOL([GTEST_CONFIG], [gtest-config])
+ GMOCK_CFLAGS=`$GMOCK_CONFIG --cppflags --cxxflags`
+ GMOCK_LIBS=`$GMOCK_CONFIG --ldflags --libs`
+ GTEST_CFLAGS=`$GTEST_CONFIG --cppflags --cxxflags`
+ GTEST_LIBS=`$GTEST_CONFIG --ldflags --libs`
+fi
+
+AC_ARG_ENABLE(selftest,
+ AS_HELP_STRING([--enable-selftest],
+ [Run extra tests with "make check" ]
+ [(may conflict with optimizations) ]
+ [(default is no)]),
+ [case "${enableval}" in
+ yes)
+ selftest=true
+ ;;
+ no)
+ selftest=false
+ ;;
+ *)
+ AC_MSG_ERROR(bad value ${enableval} for --enable-selftest)
+ ;;
+ esac],
+ [selftest=false])
+AM_CONDITIONAL(SELFTEST, test x$selftest = xtrue)
+
+AC_CONFIG_FILES(m4_flatten([
+ breakpad.pc
+ breakpad-client.pc
+ Makefile
+]))
+
+AC_OUTPUT