summaryrefslogtreecommitdiffstats
path: root/testing/mozharness/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mozharness/setup.py')
-rw-r--r--testing/mozharness/setup.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/mozharness/setup.py b/testing/mozharness/setup.py
new file mode 100644
index 000000000..5bcb36d63
--- /dev/null
+++ b/testing/mozharness/setup.py
@@ -0,0 +1,35 @@
+import os
+from setuptools import setup, find_packages
+
+try:
+ here = os.path.dirname(os.path.abspath(__file__))
+ description = open(os.path.join(here, 'README.txt')).read()
+except IOError:
+ description = ''
+
+import mozharness
+version = mozharness.version_string
+
+dependencies = ['virtualenv', 'mock', "coverage", "nose", "pylint", "pyflakes"]
+try:
+ import json
+except ImportError:
+ dependencies.append('simplejson')
+
+setup(name='mozharness',
+ version=version,
+ description="Mozharness is a configuration-driven script harness with full logging that allows production infrastructure and individual developers to use the same scripts. ",
+ long_description=description,
+ classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+ author='Aki Sasaki',
+ author_email='aki@mozilla.com',
+ url='https://hg.mozilla.org/build/mozharness/',
+ license='MPL',
+ packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=dependencies,
+ entry_points="""
+ # -*- Entry points: -*-
+ """,
+ )