summaryrefslogtreecommitdiffstats
path: root/testing/mozbase/mozprocess/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mozbase/mozprocess/setup.py')
-rw-r--r--testing/mozbase/mozprocess/setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/mozbase/mozprocess/setup.py b/testing/mozbase/mozprocess/setup.py
new file mode 100644
index 000000000..fc8225a12
--- /dev/null
+++ b/testing/mozbase/mozprocess/setup.py
@@ -0,0 +1,33 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import setup
+
+PACKAGE_VERSION = '0.23'
+
+setup(name='mozprocess',
+ version=PACKAGE_VERSION,
+ description="Mozilla-authored process handling",
+ long_description='see http://mozbase.readthedocs.org/',
+ classifiers=['Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ],
+ keywords='mozilla',
+ author='Mozilla Automation and Tools team',
+ author_email='tools@lists.mozilla.org',
+ url='https://wiki.mozilla.org/Auto-tools/Projects/Mozbase',
+ license='MPL 2.0',
+ packages=['mozprocess'],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=['mozinfo'],
+ entry_points="""
+ # -*- Entry points: -*-
+ """,
+ )