summaryrefslogtreecommitdiffstats
path: root/testing/marionette/client/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/marionette/client/setup.py')
-rw-r--r--testing/marionette/client/setup.py49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/marionette/client/setup.py b/testing/marionette/client/setup.py
new file mode 100644
index 000000000..b73b17d08
--- /dev/null
+++ b/testing/marionette/client/setup.py
@@ -0,0 +1,49 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+import os
+import re
+from setuptools import setup, find_packages
+
+THIS_DIR = os.path.dirname(os.path.realpath(__name__))
+
+
+def read(*parts):
+ with open(os.path.join(THIS_DIR, *parts)) as f:
+ return f.read()
+
+
+def get_version():
+ return re.findall("__version__ = '([\d\.]+)'",
+ read('marionette_driver', '__init__.py'), re.M)[0]
+
+
+setup(name='marionette_driver',
+ version=get_version(),
+ description="Marionette Driver",
+ long_description='See http://marionette-client.readthedocs.org/en/latest/',
+ # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)',
+ 'Operating System :: MacOS :: MacOS X',
+ 'Operating System :: Microsoft :: Windows',
+ 'Operating System :: POSIX',
+ 'Topic :: Software Development :: Quality Assurance',
+ 'Topic :: Software Development :: Testing',
+ 'Topic :: Utilities',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.7',
+ ],
+ keywords='mozilla',
+ author='Auto-tools',
+ author_email='tools-marionette@lists.mozilla.org',
+ url='https://wiki.mozilla.org/Auto-tools/Projects/Marionette',
+ license='MPL',
+ packages=find_packages(),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=read('requirements.txt').splitlines(),
+ )