summaryrefslogtreecommitdiffstats
path: root/testing/tps/setup.py
diff options
context:
space:
mode:
authorMatt A. Tobin <mattatobin@localhost.localdomain>2018-02-02 04:16:08 -0500
committerMatt A. Tobin <mattatobin@localhost.localdomain>2018-02-02 04:16:08 -0500
commit5f8de423f190bbb79a62f804151bc24824fa32d8 (patch)
tree10027f336435511475e392454359edea8e25895d /testing/tps/setup.py
parent49ee0794b5d912db1f95dce6eb52d781dc210db5 (diff)
downloadUXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.gz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.lz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.xz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.zip
Add m-esr52 at 52.6.0
Diffstat (limited to 'testing/tps/setup.py')
-rw-r--r--testing/tps/setup.py48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/tps/setup.py b/testing/tps/setup.py
new file mode 100644
index 000000000..19f109c10
--- /dev/null
+++ b/testing/tps/setup.py
@@ -0,0 +1,48 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import setup, find_packages
+import sys
+
+version = '0.5'
+
+deps = ['httplib2 == 0.9.2',
+ 'mozfile == 1.2',
+ 'mozhttpd == 0.7',
+ 'mozinfo == 0.9',
+ 'mozinstall == 1.12',
+ 'mozprocess == 0.23',
+ 'mozprofile == 0.28',
+ 'mozrunner == 6.12',
+ 'mozversion == 1.4',
+ ]
+
+# we only support python 2.6+ right now
+assert sys.version_info[0] == 2
+assert sys.version_info[1] >= 6
+
+setup(name='tps',
+ version=version,
+ description='run automated multi-profile sync tests',
+ long_description="""\
+""",
+ classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ keywords='',
+ author='Mozilla Automation and Tools team',
+ author_email='tools@lists.mozilla.org',
+ url='https://developer.mozilla.org/en-US/docs/TPS',
+ license='MPL 2.0',
+ packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=deps,
+ entry_points="""
+ # -*- Entry points: -*-
+ [console_scripts]
+ runtps = tps.cli:main
+ """,
+ data_files=[
+ ('tps', ['config/config.json.in']),
+ ],
+ )