summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMatt A. Tobin <mattatobin@localhost.localdomain>2018-02-02 04:16:08 -0500
committerMatt A. Tobin <mattatobin@localhost.localdomain>2018-02-02 04:16:08 -0500
commit5f8de423f190bbb79a62f804151bc24824fa32d8 (patch)
tree10027f336435511475e392454359edea8e25895d /configure.in
parent49ee0794b5d912db1f95dce6eb52d781dc210db5 (diff)
downloadUXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.gz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.lz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.xz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.zip
Add m-esr52 at 52.6.0
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 000000000..5b023ef9e
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# Welcome to the new world of configure. We're working on moving to a
+# python based configure. In the meanwhile, remains of the old autoconf
+# based configure is in old-configure.in.
+# If you need to add something, please come talk to the build system
+# peers for now.
+#
+# Because adding a configure file in the tree is going to conflict with
+# existing configure files in people's (and automation) work trees, and
+# because some automation jobs are still running autoconf and configure
+# "manually", this file is actually an m4 file that is processed by
+# autoconf, but doesn't call any autoconf macros. The `divert` line
+# below ensures the script that follows is output by autoconf.
+: "divert(0)dnl"
+#!/bin/sh
+
+SRCDIR=$(dirname $0)
+TOPSRCDIR="$SRCDIR"
+export OLD_CONFIGURE="$SRCDIR"/old-configure
+
+which python2.7 > /dev/null && exec python2.7 "$TOPSRCDIR/configure.py" "$@" || exec python "$TOPSRCDIR/configure.py" "$@"