summaryrefslogtreecommitdiffstats
path: root/libraries/classparser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/classparser/CMakeLists.txt')
-rw-r--r--libraries/classparser/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/libraries/classparser/CMakeLists.txt b/libraries/classparser/CMakeLists.txt
new file mode 100644
index 00000000..a6c3fa14
--- /dev/null
+++ b/libraries/classparser/CMakeLists.txt
@@ -0,0 +1,41 @@
+project(classparser)
+
+set(CMAKE_AUTOMOC ON)
+
+######## Check endianness ########
+include(TestBigEndian)
+test_big_endian(BIGENDIAN)
+if(${BIGENDIAN})
+ add_definitions(-DMULTIMC_BIG_ENDIAN)
+endif(${BIGENDIAN})
+
+# Find Qt
+find_package(Qt5Core REQUIRED)
+
+# Include Qt headers.
+include_directories(${Qt5Base_INCLUDE_DIRS})
+
+set(CLASSPARSER_HEADERS
+# Public headers
+include/classparser_config.h
+include/javautils.h
+
+# Private headers
+src/annotations.h
+src/classfile.h
+src/constants.h
+src/errors.h
+src/javaendian.h
+src/membuffer.h
+)
+
+set(CLASSPARSER_SOURCES
+src/javautils.cpp
+src/annotations.cpp
+)
+
+add_definitions(-DCLASSPARSER_LIBRARY)
+
+add_library(classparser SHARED ${CLASSPARSER_SOURCES} ${CLASSPARSER_HEADERS})
+target_include_directories(classparser PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/include")
+qt5_use_modules(classparser Core)