summaryrefslogtreecommitdiffstats
path: root/depends/xz-embedded/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'depends/xz-embedded/CMakeLists.txt')
-rw-r--r--depends/xz-embedded/CMakeLists.txt11
1 files changed, 3 insertions, 8 deletions
diff --git a/depends/xz-embedded/CMakeLists.txt b/depends/xz-embedded/CMakeLists.txt
index a71002fb..f1c6eb8d 100644
--- a/depends/xz-embedded/CMakeLists.txt
+++ b/depends/xz-embedded/CMakeLists.txt
@@ -3,7 +3,7 @@ project(xz-embedded)
option(XZ_BUILD_BCJ "Build xz-embedded with BCJ support (native binary optimization)" OFF)
option(XZ_BUILD_CRC64 "Build xz-embedded with CRC64 checksum support" ON)
-option(XZ_BUILD_MINIDEC "Build a tiny utility that decompresses xz streams" ON)
+option(XZ_BUILD_MINIDEC "Build a tiny utility that decompresses xz streams" OFF)
set(CMAKE_C_FLAGS "-std=c99")
@@ -19,6 +19,7 @@ src/xz_lzma2.h
src/xz_private.h
src/xz_stream.h
)
+# TODO: look into what would be needed for plain old lzma
# checksum checks
add_definitions(-DXZ_DEC_ANY_CHECK)
@@ -28,18 +29,12 @@ if(XZ_BUILD_CRC64)
endif()
# TODO: add SHA256
-# uncomment these, if required.
if(XZ_BUILD_BCJ)
add_definitions(-DXZ_DEC_X86 -DXZ_DEC_POWERPC -DXZ_DEC_IA64)
add_definitions(-DXZ_DEC_ARM -DXZ_DEC_ARMTHUMB -DXZ_DEC_SPARC)
LIST(APPEND XZ_SOURCES src/xz_dec_bcj.c)
endif()
-# Static link!
-ADD_DEFINITIONS(-DXZ_STATIC)
-
-add_definitions(-DXZ_LIBRARY)
-
-add_library(xz-embedded SHARED ${XZ_SOURCES})
+add_library(xz-embedded STATIC ${XZ_SOURCES})
add_executable(xzminidec xzminidec.c)
target_link_libraries(xzminidec xz-embedded)