summaryrefslogtreecommitdiffstats
path: root/depends/patchlib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'depends/patchlib/CMakeLists.txt')
-rw-r--r--depends/patchlib/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/depends/patchlib/CMakeLists.txt b/depends/patchlib/CMakeLists.txt
new file mode 100644
index 00000000..4130e08f
--- /dev/null
+++ b/depends/patchlib/CMakeLists.txt
@@ -0,0 +1,14 @@
+project(patchlib C)
+
+set(SRCS
+blocksort.c
+huffman.c
+crctable.c
+randtable.c
+compress.c
+decompress.c
+bzlib.c
+bspatch.c
+)
+
+add_library(patchlib STATIC ${SRCS})