summaryrefslogtreecommitdiffstats
path: root/depends/hoedown/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'depends/hoedown/CMakeLists.txt')
-rw-r--r--depends/hoedown/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/depends/hoedown/CMakeLists.txt b/depends/hoedown/CMakeLists.txt
new file mode 100644
index 00000000..b4ef8ef9
--- /dev/null
+++ b/depends/hoedown/CMakeLists.txt
@@ -0,0 +1,29 @@
+# hoedown 3.0.2 - https://github.com/hoedown/hoedown/archive/3.0.2.tar.gz
+project(hoedown)
+
+set(HOEDOWN_SOURCES
+hoedown/autolink.h
+hoedown/buffer.h
+hoedown/document.h
+hoedown/escape.h
+hoedown/html.h
+hoedown/stack.h
+hoedown/version.h
+src/autolink.c
+src/buffer.c
+src/document.c
+src/escape.c
+src/html.c
+src/html_blocks.c
+src/html_smartypants.c
+src/stack.c
+src/version.c
+)
+
+# Set the include dir path.
+set(HOEDOWN_INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}" PARENT_SCOPE)
+
+# Include self.
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+add_library(hoedown STATIC ${HOEDOWN_SOURCES})