summaryrefslogtreecommitdiffstats
path: root/depends/classparser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'depends/classparser/CMakeLists.txt')
-rw-r--r--depends/classparser/CMakeLists.txt41
1 files changed, 0 insertions, 41 deletions
diff --git a/depends/classparser/CMakeLists.txt b/depends/classparser/CMakeLists.txt
deleted file mode 100644
index a6c3fa14..00000000
--- a/depends/classparser/CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
-project(classparser)
-
-set(CMAKE_AUTOMOC ON)
-
-######## Check endianness ########
-include(TestBigEndian)
-test_big_endian(BIGENDIAN)
-if(${BIGENDIAN})
- add_definitions(-DMULTIMC_BIG_ENDIAN)
-endif(${BIGENDIAN})
-
-# Find Qt
-find_package(Qt5Core REQUIRED)
-
-# Include Qt headers.
-include_directories(${Qt5Base_INCLUDE_DIRS})
-
-set(CLASSPARSER_HEADERS
-# Public headers
-include/classparser_config.h
-include/javautils.h
-
-# Private headers
-src/annotations.h
-src/classfile.h
-src/constants.h
-src/errors.h
-src/javaendian.h
-src/membuffer.h
-)
-
-set(CLASSPARSER_SOURCES
-src/javautils.cpp
-src/annotations.cpp
-)
-
-add_definitions(-DCLASSPARSER_LIBRARY)
-
-add_library(classparser SHARED ${CLASSPARSER_SOURCES} ${CLASSPARSER_HEADERS})
-target_include_directories(classparser PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/include")
-qt5_use_modules(classparser Core)