summaryrefslogtreecommitdiffstats
path: root/depends/classparser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'depends/classparser/CMakeLists.txt')
-rw-r--r--depends/classparser/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/depends/classparser/CMakeLists.txt b/depends/classparser/CMakeLists.txt
new file mode 100644
index 00000000..5a48e002
--- /dev/null
+++ b/depends/classparser/CMakeLists.txt
@@ -0,0 +1,41 @@
+project(classparser)
+
+set(CMAKE_AUTOMOC ON)
+
+# Find Qt
+find_package(Qt5Core REQUIRED)
+
+# Include Qt headers.
+include_directories(${Qt5Base_INCLUDE_DIRS})
+
+SET(CLASSPARSER_HEADERS
+include/classparser_config.h
+
+# Public headers
+include/javautils.h
+
+# Private headers
+src/annotations.h
+src/classfile.h
+src/constants.h
+src/errors.h
+src/javaendian.h
+src/membuffer.h
+)
+
+SET(CLASSPARSER_SOURCES
+src/javautils.cpp
+src/annotations.cpp
+)
+
+# Set the include dir path.
+SET(LIBGROUPVIEW_INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include" PARENT_SCOPE)
+
+# Include self.
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+add_definitions(-DCLASSPARSER_LIBRARY)
+
+add_library(classparser SHARED ${CLASSPARSER_SOURCES} ${CLASSPARSER_HEADERS})
+qt5_use_modules(classparser Core)