summaryrefslogtreecommitdiffstats
path: root/api/logic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'api/logic/CMakeLists.txt')
-rw-r--r--api/logic/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/api/logic/CMakeLists.txt b/api/logic/CMakeLists.txt
index b534f970..32f5fd12 100644
--- a/api/logic/CMakeLists.txt
+++ b/api/logic/CMakeLists.txt
@@ -157,6 +157,13 @@ set(NEWS_SOURCES
news/NewsEntry.cpp
)
+# Icon interface
+set(ICONS_SOURCES
+ # News System
+ icons/IIconList.h
+ icons/IIconList.cpp
+)
+
# Minecraft services status checker
set(STATUS_SOURCES
# Status system
@@ -433,6 +440,7 @@ set(LOGIC_SOURCES
${TRANSLATIONS_SOURCES}
${TOOLS_SOURCES}
${WONKO_SOURCES}
+ ${ICONS_SOURCES}
)
add_library(MultiMC_logic SHARED ${LOGIC_SOURCES})