summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ecfb690..a02a4b27 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,9 @@
cmake_minimum_required(VERSION 2.8.9)
-# In Qt 5.1+ we have our own main() function, don't autolink to qtmain on Windows
-cmake_policy(SET CMP0020 OLD)
+IF(WIN32)
+ # In Qt 5.1+ we have our own main() function, don't autolink to qtmain on Windows
+ cmake_policy(SET CMP0020 OLD)
+ENDIF()
project(MultiMC)
@@ -308,6 +310,9 @@ logic/tasks/ProgressProvider.h
logic/tasks/Task.h
logic/tasks/Task.cpp
+# Utilities
+logic/JavaUtils.h
+logic/JavaUtils.cpp
)