summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2fcc55f..bb8d7671 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,10 @@ SET(CMAKE_INCLUDE_CURRENT_DIR ON)
# Output all executables and shared libs in the main build folder, not in subfolders.
SET(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
+IF(UNIX)
+ SET(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
+ENDIF()
+
######## Set compiler flags ########
IF(APPLE)
# assume clang 4.1.0+, add C++0x/C++11 stuff
@@ -331,11 +335,7 @@ INSTALL(CODE "
# Dirs to look for dependencies.
-SET(DIRS "${QT_LIBRARY_DIRS}
-${CMAKE_BINARY_DIR}/libutil
-${CMAKE_BINARY_DIR}/libsettings
-${CMAKE_BINARY_DIR}/libinstance")
-message(STATUS "${DIRS}")
+SET(DIRS "${QT_LIBRARY_DIRS}")
INSTALL(CODE "
file(GLOB_RECURSE QTPLUGINS