summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt51
1 files changed, 14 insertions, 37 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 79a69225..95b1c18f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,6 +97,9 @@ include_directories(${LIBSETTINGS_INCLUDE_DIR})
add_subdirectory(depends/groupview)
include_directories(${LIBGROUPVIEW_INCLUDE_DIR})
+# Add the updater
+add_subdirectory(mmc_updater)
+
################################ SET UP BUILD OPTIONS ################################
######## Check endianness ########
@@ -129,10 +132,10 @@ ENDIF ()
MESSAGE(STATUS "MultiMC 5 version ${MultiMC_VERSION_STRING}")
-# Custom target to just print the version.
+#### Custom target to just print the version.
ADD_CUSTOM_TARGET(version echo "Version: ${MultiMC_VERSION_STRING}")
-# Check the current Git commit
+#### Check the current Git commit
execute_process(COMMAND git rev-parse HEAD
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
RESULT_VARIABLE GIT_COMMIT_CHECK_RESULTVAR
@@ -140,7 +143,6 @@ execute_process(COMMAND git rev-parse HEAD
OUTPUT_STRIP_TRAILING_WHITESPACE
)
-# If Git executed successfully
IF(GIT_COMMIT_CHECK_RESULTVAR EQUAL 0)
SET(MultiMC_GIT_COMMIT "${GIT_COMMIT_CHECK_OUTVAR}")
MESSAGE(STATUS "Git commit: ${MultiMC_GIT_COMMIT}")
@@ -149,41 +151,12 @@ ELSE()
MESSAGE(STATUS "Failed to check Git commit. ${GIT_COMMIT_CHECK_RESULTVAR}")
ENDIF()
-
-######## Set Jenkins info ########
-# Jenkins build tag
-IF(DEFINED MultiMC_BUILD_TAG)
- MESSAGE(STATUS "Build tag: ${MultiMC_BUILD_TAG}")
-ELSE()
- MESSAGE(STATUS "No build tag specified.")
- SET(MultiMC_BUILD_TAG custom)
-ENDIF()
-
-# Architecture detection
-IF(CMAKE_SIZEOF_VOID_P EQUAL 8)
- SET(MultiMC_ARCH "x64" CACHE STRING "Architecture we're building for.")
-ELSE()
- SET(MultiMC_ARCH "x86" CACHE STRING "Architecture we're building for.")
-ENDIF()
-MESSAGE(STATUS "Architecture is ${MultiMC_ARCH}")
-
-# Jenkins job name
-IF(WIN32)
- SET(MultiMC_JOB_NAME "MultiMC5Windows" CACHE STRING "Jenkins job name.")
-ELSEIF(UNIX AND APPLE)
- SET(MultiMC_JOB_NAME "MultiMC5OSX" CACHE STRING "Jenkins job name.")
-ELSE()
- SET(MultiMC_JOB_NAME "MultiMC5Linux" CACHE STRING "Jenkins job name.")
-ENDIF()
-
-# Jenkins URL
-SET(MultiMC_JOB_URL "http://ci.forkk.net/job/${MultiMC_JOB_NAME}/arch=${MultiMC_ARCH}${MultiMC_Extra_Label}/"
- CACHE STRING "URL of the jenkins job to pull updates from.")
-MESSAGE(STATUS "Job URL: ${MultiMC_JOB_URL}")
+#### GoUpdate URL
+SET(MultiMC_REPO_BASE_URL "invalid" CACHE STRING "Base URL for the updater.")
+SET(MultiMC_VERSION_BRANCH "invalid" CACHE STRING "URL of the stable update repo.")
######## Configure header ########
-configure_file("${PROJECT_SOURCE_DIR}/config.h.in"
- "${PROJECT_BINARY_DIR}/include/config.h")
+configure_file("${PROJECT_SOURCE_DIR}/config.h.in" "${PROJECT_BINARY_DIR}/include/config.h")
######## Other Stuff ########
@@ -251,6 +224,8 @@ gui/dialogs/AccountListDialog.h
gui/dialogs/AccountListDialog.cpp
gui/dialogs/AccountSelectDialog.h
gui/dialogs/AccountSelectDialog.cpp
+gui/dialogs/UpdateDialog.h
+gui/dialogs/UpdateDialog.cpp
# GUI - widgets
gui/widgets/InstanceDelegate.h
@@ -383,7 +358,8 @@ logic/NagUtils.h
logic/NagUtils.cpp
logic/SkinUtils.h
logic/SkinUtils.cpp
-
+logic/GoUpdate.h
+logic/GoUpdate.cpp
)
@@ -410,6 +386,7 @@ gui/dialogs/EditNotesDialog.ui
gui/dialogs/AccountListDialog.ui
gui/dialogs/AccountSelectDialog.ui
gui/dialogs/EditAccountDialog.ui
+gui/dialogs/UpdateDialog.ui
# Widgets/other
gui/widgets/MCModInfoFrame.ui