summaryrefslogtreecommitdiffstats
path: root/quazip/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew <forkk@forkk.net>2013-04-01 12:04:40 -0500
committerAndrew <forkk@forkk.net>2013-04-01 12:04:40 -0500
commit276cfb18a680407ca39feaaf860d4c6ee6015213 (patch)
treeb1637108085027f59ac2143c7b034d8739319507 /quazip/CMakeLists.txt
parentebb2c54975e3f0b7b891532e8e72d2ef760f96c4 (diff)
downloadMultiMC-276cfb18a680407ca39feaaf860d4c6ee6015213.tar
MultiMC-276cfb18a680407ca39feaaf860d4c6ee6015213.tar.gz
MultiMC-276cfb18a680407ca39feaaf860d4c6ee6015213.tar.lz
MultiMC-276cfb18a680407ca39feaaf860d4c6ee6015213.tar.xz
MultiMC-276cfb18a680407ca39feaaf860d4c6ee6015213.zip
Fix quazip issues.
Diffstat (limited to 'quazip/CMakeLists.txt')
-rw-r--r--quazip/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/quazip/CMakeLists.txt b/quazip/CMakeLists.txt
index b245653f..b5a391e9 100644
--- a/quazip/CMakeLists.txt
+++ b/quazip/CMakeLists.txt
@@ -1,3 +1,5 @@
+project(quazip)
+
# set all include directories for in and out of source builds
include_directories(
${CMAKE_CURRENT_SOURCE_DIR}
@@ -11,8 +13,8 @@ include_directories(
file(GLOB SRCS "*.c" "*.cpp")
file(GLOB PUBLIC_HEADERS "*.h")
-# Must be added to enable export macro
-ADD_DEFINITIONS(-DQUAZIP_BUILD)
+# Static link!
+ADD_DEFINITIONS(-DQUAZIP_STATIC)
#qt5_wrap_cpp(MOC_SRCS ${PUBLIC_HEADERS})
#set(SRCS ${SRCS} ${MOC_SRCS})