summaryrefslogtreecommitdiffstats
path: root/mmc_updater/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2014-04-21 23:33:00 +0200
committerPetr Mrázek <peterix@gmail.com>2014-04-21 23:33:00 +0200
commit9d724e0fe4bfb7b7940f3f0c9719affd22a18722 (patch)
treec73e9566e134d2b78e6f1b8bce3c32159b17675f /mmc_updater/src/tests/CMakeLists.txt
parenta9dfe6d7ec949954b07facff71ee6023e0ced9ee (diff)
parenta00fb1e8da505768b491e5f4d6266784fb1a27c9 (diff)
downloadMultiMC-9d724e0fe4bfb7b7940f3f0c9719affd22a18722.tar
MultiMC-9d724e0fe4bfb7b7940f3f0c9719affd22a18722.tar.gz
MultiMC-9d724e0fe4bfb7b7940f3f0c9719affd22a18722.tar.lz
MultiMC-9d724e0fe4bfb7b7940f3f0c9719affd22a18722.tar.xz
MultiMC-9d724e0fe4bfb7b7940f3f0c9719affd22a18722.zip
Merge remote-tracking branch 'origin/feature_cmake_style' into develop
Conflicts: CMakeLists.txt
Diffstat (limited to 'mmc_updater/src/tests/CMakeLists.txt')
-rw-r--r--mmc_updater/src/tests/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/mmc_updater/src/tests/CMakeLists.txt b/mmc_updater/src/tests/CMakeLists.txt
index 08501a98..5a96d7c9 100644
--- a/mmc_updater/src/tests/CMakeLists.txt
+++ b/mmc_updater/src/tests/CMakeLists.txt
@@ -1,8 +1,8 @@
include_directories("${CMAKE_CURRENT_SOURCE_DIR}/..")
-if (APPLE)
- set(HELPER_SHARED_SOURCES ../StlSymbolsLeopard.cpp)
+if(APPLE)
+ set(HELPER_SHARED_SOURCES ../StlSymbolsLeopard.cpp)
endif()
# # Create helper binaries for unit tests
@@ -17,14 +17,14 @@ endif()
# Install data files required by unit tests
set(TEST_FILES
- file_list.xml
+ file_list.xml
)
foreach(TEST_FILE ${TEST_FILES})
- execute_process(
- COMMAND
- "${CMAKE_COMMAND}" -E copy_if_different "${CMAKE_CURRENT_SOURCE_DIR}/${TEST_FILE}" "${CMAKE_CURRENT_BINARY_DIR}"
- )
+ execute_process(
+ COMMAND
+ "${CMAKE_COMMAND}" -E copy_if_different "${CMAKE_CURRENT_SOURCE_DIR}/${TEST_FILE}" "${CMAKE_CURRENT_BINARY_DIR}"
+ )
endforeach()
# Add unit test binaries
@@ -32,13 +32,13 @@ macro(ADD_UPDATER_TEST CLASS)
set(TEST_TARGET updater_${CLASS})
unset(srcs)
list(APPEND srcs ${CLASS}.cpp)
- if (WIN32)
+ if(WIN32)
list(APPEND srcs ${CMAKE_CURRENT_SOURCE_DIR}/test.rc)
endif()
add_executable(${TEST_TARGET} ${srcs})
target_link_libraries(${TEST_TARGET} updatershared)
add_test(NAME ${TEST_TARGET} COMMAND ${TEST_TARGET})
- if (APPLE)
+ if(APPLE)
set_target_properties(${TEST_TARGET} PROPERTIES LINK_FLAGS "-framework Security -framework Cocoa")
endif()
endmacro()